False detections of banned users

Moderator: Site Moderators

Post Reply
toTOW
Site Moderator
Posts: 8717
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France
Contact:

False detections of banned users

Post by toTOW » Tue Apr 09, 2019 9:56 pm

I received reports form forum users that the forum software might not detect ban rules correctly and then issue reports of ban to legitimate users.

I don't know what causes this at the moment, but here what we know :
- On my phone, I was able to get in by switching carrier (I have a phone with two SIMs from different carriers).
- I got reports of successful log in after using a different device on the same network (for instance PC vs. tablet or smartphone).
- I also got a report that using a different browser on the same machine would work too

If you're affected by the issue, you may try one of the workaround above until we figure out what's wrong behind the scenes ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image

Paragon
Posts: 24
Joined: Fri Oct 21, 2011 3:24 am
Hardware configuration: Rig1 (Dedicated SMP): AMD Phenom II X6 1100T, Gigabyte GA-880GMA-USB3 board, 8 GB Kingston 1333 DDR3 Ram, Seasonic S12 II 380 Watt PSU, Noctua CPU Cooler

Rig2 (Part-Time GPU): Intel Q6600, Gigabyte 965P-S3 Board, EVGA 460 GTX Graphics, 8 GB Kingston 800 DDR2 Ram, Seasonic Gold X-650 PSU, Artic Cooling Freezer 7 CPU Cooler
Location: United States

Re: False detections of banned users

Post by Paragon » Wed Apr 10, 2019 3:03 am

This just happened to me...it said it was an IP ban. None of the computers in my house or my phone would access the site. The fix was to use an online proxy server to log in...seems to be fine now though (am logged in normally without the proxy).

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: False detections of banned users

Post by Joe_H » Wed Apr 10, 2019 3:28 am

If you happen to know the IP address your login was coming from, please send it to me in a PM.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

bollix47
Posts: 3483
Joined: Sun Dec 02, 2007 5:04 am
Hardware configuration: 1. Dual 6 core Xeons @ 2.66Ghz;16 gig;Ubuntu 64 bit;970;v7-gpu

2. Dual 4 core Xeons @ 2.54Ghz;12 gig;Ubuntu 64 bit;1070;v7-gpu

3. AMD 8350 @ 4Ghz;4 gig;1070;Ubuntu 64 bit;v7-gpu

4. i5 7600K @ 3.8Ghz;8 gig;960+1060;Win 10 pro 64 bit;v7-gpu

5. 4 x 6274 @ 2.2Ghz;16 gig;Linux Ubuntu 64 bit;v7-cpu:54;

6. G3258 @ 3.2Ghz;8 gig;980;Ubuntu 64 bit;v7-gpu

7. Ryzen 5 2600x @ 3.9Ghz;16 gig;1080;Ubuntu 64 bit;v7-gpu

8. i7 940 @ 2.94Ghz;4 gig;980ti;Ubuntu 64 bit;v7-gpu

9. Predator laptop - win 10 - 1070
Location: Canada

Re: False detections of banned users

Post by bollix47 » Wed Apr 10, 2019 8:47 am

FYI
The message I and others saw yesterday:

Code: Select all

You have been banned from this board until Tue May 07, 2019 5:46 pm.

Please contact the Board Administrator for more information.

A ban has been issued on your IP address.
is no longer showing here and I'm not seeing any problem so far today. :?

kbeeveer46
Posts: 11
Joined: Thu Jan 24, 2019 1:14 am

Re: False detections of banned users

Post by kbeeveer46 » Wed Apr 10, 2019 12:47 pm

I got the ban message, as well. It said I was IP banned so I connected to my work VPN and it still said I was banned. I no longer get the banned message this morning.

kiore
Posts: 991
Joined: Fri Jan 16, 2009 5:45 pm
Location: USA

Re: False detections of banned users

Post by kiore » Wed Apr 10, 2019 3:48 pm

kbeeveer46 wrote:I got the ban message, as well. It said I was IP banned so I connected to my work VPN and it still said I was banned. I no longer get the banned message this morning.

Yes I had a similar issues, used 3 different IPs and all said I was banned, now (obviously) that nolonger happening.
Image

i7 7800x GTX 1080ti , OS= win7. AMD 3700x RTX 2080ti OS= win10

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: False detections of banned users

Post by bruce » Wed Apr 10, 2019 5:31 pm

Most likely the ban was applied to some kind of a gateway between each of you and the FAH servers. I suppose if we collect a few tracert (traceroute) reports, we could figure it out, but what's the point. It appears to have been resolved without an explanation.

If something like this happens again, maybe we can gather enough data to learn more about it.

Nert
Posts: 155
Joined: Wed Mar 26, 2014 7:46 pm

Re: False detections of banned users

Post by Nert » Wed Apr 10, 2019 7:40 pm

bruce wrote:If something like this happens again, maybe we can gather enough data to learn more about it.
So if this re-occurs we should gather trace route and local IP addresses ? Anything else ?

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: False detections of banned users

Post by bruce » Thu Apr 11, 2019 4:44 am

Yes, traceroute foldingforum.org (or tracert foldingforum.org) and then we compare the results from various locations around the world.

It's not likely to ever happen again. I don't remember it ever happening before in the dozen or so years I've been here.

toTOW
Site Moderator
Posts: 8717
Joined: Sun Dec 02, 2007 10:38 am
Location: Bordeaux, France
Contact:

Re: False detections of banned users

Post by toTOW » Sat Apr 13, 2019 12:10 pm

I didn't found any ban rule on the forum settings that would match the IP I had which were reported as banned ... that's probably some other kind of bug (maybe forum software/server failing to identify the correct IP) ...
Folding@Home beta tester since 2002. Folding Forum moderator since July 2008.

FAH-Addict : latest news, tests and reviews about Folding@Home project.

Image

Post Reply

Return to “Issues with this forum”