Page 1 of 2

ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 4:00 pm
by DocJonz
I'm having a similar issue to this thread GTX 780 Ti - Bad PlatformId Size SOLVED: RDP problem.
I'm trying to run a GTX 780 under Ubuntu 13.10, and have managed (after a lot of pain!) to get the nVidia 331.49 drivers running. BUT, I keep getting the "ERROR:exception: Bad platformId size" message, so it eventually fails after a number of goes. I've got a monitor connected directly, so it's not the same remote desktop problem. Any thoughts?

Code: Select all

15:46:09:WU01:FS01:0x17:*********************** Log Started 2014-03-24T15:46:09Z ***********************
15:46:09:WU01:FS01:0x17:Project: 13001 (Run 135, Clone 8, Gen 0)
15:46:09:WU01:FS01:0x17:Unit: 0x00000000538b3db75328761a0f67477e
15:46:09:WU01:FS01:0x17:CPU: 0x00000000000000000000000000000000
15:46:09:WU01:FS01:0x17:Machine: 1
15:46:09:WU01:FS01:0x17:Reading tar file system.xml
15:46:09:WU01:FS01:0x17:Reading tar file integrator.xml
15:46:09:WU01:FS01:0x17:Reading tar file state.xml
15:46:10:WU01:FS01:0x17:Reading tar file core.xml
15:46:10:WU01:FS01:0x17:Digital signatures verified
15:46:10:WU01:FS01:0x17:ERROR:exception: Bad platformId size.
15:46:10:WU01:FS01:0x17:Saving result file logfile_01.txt
15:46:10:WU01:FS01:0x17:Saving result file log.txt
15:46:11:WU01:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
15:46:11:WARNING:WU01:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
15:46:11:WU01:FS01:Sending unit results: id:01 state:SEND error:FAULTY project:13001 run:135 clone:8 gen:0 core:0x17 unit:0x00000000538b3db75328761a0f67477e
15:46:11:WU01:FS01:Uploading 1.81KiB to 140.163.4.231
15:46:11:WU01:FS01:Connecting to 140.163.4.231:8080
15:46:11:WU02:FS01:Connecting to 171.67.108.201:80
15:46:11:WU01:FS01:Upload complete
15:46:11:WU01:FS01:Server responded WORK_ACK (400)
15:46:11:WU01:FS01:Cleaning up
15:46:12:WU02:FS01:Assigned to work server 140.163.4.231
15:46:12:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GK110 [GeForce GTX 780] from 140.163.4.231
15:46:12:WU02:FS01:Connecting to 140.163.4.231:8080
15:46:13:WU02:FS01:Downloading 5.22MiB
15:46:14:WU02:FS01:Download complete
15:46:15:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:13001 run:136 clone:8 gen:0 core:0x17 unit:0x00000000538b3db7532876626c791f85
15:46:15:WU02:FS01:Starting
15:46:15:WU02:FS01:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/www.stanford.edu/~pande/Linux/AMD64/NVIDIA/Fermi/Core_17.fah/FahCore_17 -dir 02 -suffix 01 -version 704 -lifeline 1146 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
15:46:15:WU02:FS01:Started FahCore on PID 2680
15:46:15:WU02:FS01:Core PID:2684
15:46:15:WU02:FS01:FahCore 0x17 started
15:46:15:WU02:FS01:0x17:*********************** Log Started 2014-03-24T15:46:15Z ***********************
15:46:15:WU02:FS01:0x17:Project: 13001 (Run 136, Clone 8, Gen 0)
15:46:15:WU02:FS01:0x17:Unit: 0x00000000538b3db7532876626c791f85
15:46:15:WU02:FS01:0x17:CPU: 0x00000000000000000000000000000000
15:46:15:WU02:FS01:0x17:Machine: 1
15:46:15:WU02:FS01:0x17:Reading tar file system.xml
15:46:15:WU02:FS01:0x17:Reading tar file integrator.xml
15:46:15:WU02:FS01:0x17:Reading tar file state.xml
15:46:16:WU02:FS01:0x17:Reading tar file core.xml
15:46:16:WU02:FS01:0x17:Digital signatures verified
15:46:16:WU02:FS01:0x17:ERROR:exception: Bad platformId size.
15:46:16:WU02:FS01:0x17:Saving result file logfile_01.txt
15:46:16:WU02:FS01:0x17:Saving result file log.txt
15:46:16:WU02:FS01:0x17:Folding@home Core Shutdown: BAD_WORK_UNIT
15:46:17:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
15:46:17:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:13001 run:136 clone:8 gen:0 core:0x17 unit:0x00000000538b3db7532876626c791f85
15:46:17:WU02:FS01:Uploading 1.81KiB to 140.163.4.231
15:46:17:WU02:FS01:Connecting to 140.163.4.231:8080
15:46:17:WU02:FS01:Upload complete
15:46:17:WU02:FS01:Server responded WORK_ACK (400)
15:46:17:WU02:FS01:Cleaning up

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 6:18 pm
by 7im
What was the source of the v331.49 drivers?

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 6:30 pm
by DocJonz
Via these commands;

Code: Select all

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 10:41 pm
by DocJonz
Just upgraded to Ubuntu 14.04 beta which brings the 331.38 drivers in via the standard Software Updater.
Unfortunately, the fahclient and fahcontrol packages (v7.4.4 or v7.3.6) will not install. Doh!

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 10:56 pm
by ChristianVirtual
What is the error ?
Did you checked on the python versions ? Which one comes with 14.04 ?
See https://folding.stanford.edu/home/guide ... all-guide/ Down the page ...

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 11:16 pm
by P5-133XL
Could you please post the system and config portions of the folding log?

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 11:26 pm
by DocJonz
ChristianVirtual wrote:What is the error ?
Did you checked on the python versions ? Which one comes with 14.04 ?
See https://folding.stanford.edu/home/guide ... all-guide/ Down the page ...

Message was "Package operation failed".
It seems 14.04 comes with Python 3 by default (though 2.7 is said to be in the archive)

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Mon Mar 24, 2014 11:28 pm
by DocJonz
P5-133XL wrote:Could you please post the system and config portions of the folding log?

I did a clean install of 14.04, so I'm afraid there are no other 13.10 logs - did get the config bit though;

Code: Select all

15:45:52:<config>
15:45:52:  <!-- Client Control -->
15:45:52:  <fold-anon v='true'/>
15:45:52:
15:45:52:  <!-- Folding Slot Configuration -->
15:45:52:  <gpu v='false'/>
15:45:52:
15:45:52:  <!-- Network -->
15:45:52:  <proxy v=':8080'/>
15:45:52:
15:45:52:  <!-- Slot Control -->
15:45:52:  <power v='full'/>
15:45:52:
15:45:52:  <!-- User Information -->
15:45:52:  <passkey v='********************************'/>
15:45:52:  <team v='35947'/>
15:45:52:  <user v='DocJonz'/>
15:45:52:
15:45:52:  <!-- Folding Slots -->
15:45:52:  <slot id='0' type='CPU'>
15:45:52:    <cpus v='10'/>
15:45:52:  </slot>
15:45:52:  <slot id='1' type='GPU'/>
15:45:52:</config>

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 2:28 am
by PantherX
This could potentially be the issue:
15:45:52: <gpu v='false'/>

You can either make the value true or remove it. To do so, please open up FAHControl -> Configure -> Expert Tab -> Extra client options and over there, make the appropriate change.

Also, please post the system information so we can see what hardware and software F@H has detected on your system.

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 7:28 am
by DocJonz
PantherX wrote:This could potentially be the issue:
15:45:52: <gpu v='false'/>

You can either make the value true or remove it. To do so, please open up FAHControl -> Configure -> Expert Tab -> Extra client options and over there, make the appropriate change.

Also, please post the system information so we can see what hardware and software F@H has detected on your system.

As mentioned above, I'm now running 14.04 beta, and since the client or control won't install at present, I have no logs.
If the Python thing that ChristianVirtual mentions works, and I get it running (I'll try later today), I'll post them then.

It is perhaps worth noting that Ubuntu 14.04 will be an LTS version, so a smooth client installation is going to be absolutely essential come April 17th ....

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 7:33 am
by 7im
PantherX wrote:This could potentially be the issue:
15:45:52: <gpu v='false'/>

You can either make the value true or remove it. To do so, please open up FAHControl -> Configure -> Expert Tab -> Extra client options and over there, make the appropriate change.

Also, please post the system information so we can see what hardware and software F@H has detected on your system.


You can't change that setting if the OS doesn't see the device because of a driver issue. Bad Platformid is often caused by bad driver install, or missing driver component.

Then use the python work around in the install guide.

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 2:54 pm
by bollix47
@DocJonz

I did a fresh install of 14.04 beta this morning and have seen no problems. The one piece of software I use when installing the folding deb files is gdebi:

sudo apt-get install gdebi

Then, using file manager (nautilus), I navigate to the download location, right-click on the deb file and select open with Gdebi. No errors and no additional linking was required.

For your 780 click on the Dash and type Software ... look for Software & Updates and click on it ... click on the Additional Drivers tab and select nvidia-331 (not nvidia-331-updates). Anyone with a GPU model lower than the 780 should use nvidia-304. No need to install xorg-edgers but since you've already done that you should be fine using their repository. When it's finished updating I always reboot.

After the reboot you can again visit the Dash and type nvidia-settings, click on it and the initial display should show the version you are using.

If you need to adjust your fan speed see this guide.

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 7:07 pm
by DocJonz
@Bollix47
Thanks for the tips.
Installed gdebi and that allowed me to get the fahclient and fahcontrol packages on (I've used 7.3.6, as 7.4.4 isn't supported by HFM yet).
It recognised the CPU. But when I try to add a GPU slot, I get a dialogue box that says;
On client "local" 127.0.0.1:36330: No more GPU's
No more indeed ... I can't get one working :-)

System below;

Code: Select all

*********************** Log Started 2014-03-25T18:52:56Z ***********************
18:52:56:************************* Folding@home Client *************************
18:52:56:    Website: http://folding.stanford.edu/
18:52:56:  Copyright: (c) 2009-2013 Stanford University
18:52:56:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
18:52:56:       Args: --child --lifeline 1105 /etc/fahclient/config.xml --run-as
18:52:56:             fahclient --pid-file=/var/run/fahclient.pid --daemon
18:52:56:     Config: /etc/fahclient/config.xml
18:52:56:******************************** Build ********************************
18:52:56:    Version: 7.3.6
18:52:56:       Date: Feb 18 2013
18:52:56:       Time: 07:24:08
18:52:56:    SVN Rev: 3923
18:52:56:     Branch: fah/trunk/client
18:52:56:   Compiler: GNU 4.4.7
18:52:56:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
18:52:56:             -fno-unsafe-math-optimizations -msse2
18:52:56:   Platform: linux2 3.2.0-1-amd64
18:52:56:       Bits: 64
18:52:56:       Mode: Release
18:52:56:******************************* System ********************************
18:52:56:        CPU: Intel(R) Core(TM) i7 CPU 980 @ 3.33GHz
18:52:56:     CPU ID: GenuineIntel Family 6 Model 44 Stepping 2
18:52:56:       CPUs: 12
18:52:56:     Memory: 5.82GiB
18:52:56:Free Memory: 5.51GiB
18:52:56:    Threads: POSIX_THREADS
18:52:56:Has Battery: false
18:52:56: On Battery: false
18:52:56: UTC offset: 0
18:52:56:        PID: 1231
18:52:56:        CWD: /var/lib/fahclient
18:52:56:         OS: Linux 3.13.0-19-generic x86_64
18:52:56:    OS Arch: AMD64
18:52:56:       GPUs: 0
18:52:56:       CUDA: 3.5
18:52:56:CUDA Driver: 6000

Config below;

Code: Select all

18:54:13:Saving configuration to /etc/fahclient/config.xml
18:54:13:<config>
18:54:13:  <!-- Client Control -->
18:54:13:  <fold-anon v='true'/>
18:54:13:
18:54:13:  <!-- Folding Slot Configuration -->
18:54:13:  <power v='full'/>
18:54:13:
18:54:13:  <!-- HTTP Server -->
18:54:13:  <allow v='127.0.0.1,192.168.1.0/24'/>
18:54:13:
18:54:13:  <!-- Network -->
18:54:13:  <proxy v=':8080'/>
18:54:13:
18:54:13:  <!-- Remote Command Server -->
18:54:13:  <password v='*******'/>
18:54:13:
18:54:13:  <!-- User Information -->
18:54:13:  <passkey v='********************************'/>
18:54:13:  <team v='35947'/>
18:54:13:  <user v='DocJonz'/>
18:54:13:
18:54:13:  <!-- Folding Slots -->
18:54:13:  <slot id='0' type='CPU'>
18:54:13:    <cpus v='10'/>
18:54:13:  </slot>
18:54:13:</config>
19:02:12:WU00:FS00:0xa3:Completed 5000 out of 500000 steps  (1%)

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 7:09 pm
by bollix47

Re: ERROR: Bad platformId size (GTX 780 / Ubuntu 13.10)

Posted: Tue Mar 25, 2014 7:16 pm
by bollix47
As you can see in the System Info section your GPU has not been recognized by the client. This could be the result of improper driver installation. Have you rebooted since you installed those drivers? If so you may have to completely reinstall the drivers. Until the client recognizes your GPU you won't be able to add a GPU slot.