Tips for installing Nvidia .run files in Linux

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Tips for installing Nvidia .run files in Linux

Post by bruce » Thu Feb 26, 2015 7:29 pm

I though so, too, but the copy distributed in the install package would be whatever was current at the time it was packaged. Later, the client should install the updated version, but that rarely happens promptly enough.

Was the fine missing entirely, or just obsolete?

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: Tips for installing Nvidia .run files in Linux

Post by Joe_H » Thu Feb 26, 2015 9:35 pm

7.4.4 does come with a built-in white/black list, but that dates back a while. It needs to download GPUs.txt to recognize a number of cards introduced after 7.4.4 was finalized.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by 7im » Thu Feb 26, 2015 9:51 pm

V7.4.4 is better about trying to update the GPUs.txt file than previous versions. But it may only try again when the client is stopped and restarted, and we're not usually that patient. We see it missing, or not working, and pull out the big hammer instead of letting it try to fix itself.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

Jesse_V
Posts: 2773
Joined: Mon Jul 18, 2011 4:44 am
Hardware configuration: OS: Ubuntu 17.04
CPU: i7-6700k
GPU: GTX 970
RAM: 32 GB DDR4
Location: USA
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by Jesse_V » Fri Feb 27, 2015 8:58 pm

7im wrote:V7.4.4 is better about trying to update the GPUs.txt file than previous versions. But it may only try again when the client is stopped and restarted, and we're not usually that patient. We see it missing, or not working, and pull out the big hammer instead of letting it try to fix itself.

I restarted several times and spent a couple hours digging in to my system, trying to investigate why Nvidia, lshw, and lspci all listed a card on that PCI bus, but F@h didn't. Then I realized my mistake, fetched GPUs.txt (which didn't exist on my system), the restarted F@h. Low and behold, the 970 was recognized.
Pen tester at Cigital/Synopsys

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Tips for installing Nvidia .run files in Linux

Post by bruce » Fri Feb 27, 2015 9:03 pm

I clobbered my Ubuntu system. The procedure needs a warning.

I had installed a package with the 3.13 drivers produced by someone other than nVidia. I failed to remove that package and to restore nouveau before starting the procedure. Now the .run file fails. [Yes, we all know about doing a driver cleaning before installing new drivers....]

DocJonz
Posts: 357
Joined: Thu Dec 06, 2007 6:31 pm
Hardware configuration: 1. Farm1: i7 930, ASUS P6TD X58, 2x GTX 1070, Ubuntu 16.04
2. Farm2: i7 930, ASUS P6TD X58, 2x GTX 1070, Ubuntu 16.04
3. Farm3: i7 4790K, ASUS Z97 Pro, 2x GTX 1070, Ubuntu 16.04
4. Study: i7 3930k, ASUS Sabertooth X79, 2x GTX 1080, Ubuntu 16.04
Location: United Kingdom
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by DocJonz » Sat Feb 28, 2015 4:09 pm

I had the same issue as Jesse - GPUs.txt was not on the system after installing v7.4.4. It did not try to get the file, even after a restart, I had to add it manually.

To avoid the pain for other users, is it not possible for the install package to be rebuilt with a more recent version of GPUs.txt, i.e. one that includes Maxwell cards in this case?
(Please note I'm not proposing that this is done every time a new GPU comes out, but since the v7.4.4 package itself has been around for nearly a year now, it would seem like it was time for a simple update).

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Tips for installing Nvidia .run files in Linux

Post by bruce » Sat Feb 28, 2015 5:13 pm

The package you're proposing is already present in v7.4.4 but it doesn't always work. In many cases, FAHClient.exe starts up before the internet connection is established ... checks for an update (which fails) ... and goes on to initialize folding. I'll bet that a sudo /etc/init.d/FAHClient restart would have performed the update for you (assuming you waited until network initialization had completed).

If you still want the Pande Group to consider the enhancement, please post your suggestion on the FAH subreddit.

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by 7im » Sat Feb 28, 2015 5:24 pm

Jesse_V wrote:
7im wrote:V7.4.4 is better about trying to update the GPUs.txt file than previous versions. But it may only try again when the client is stopped and restarted, and we're not usually that patient. We see it missing, or not working, and pull out the big hammer instead of letting it try to fix itself.

I restarted several times and spent a couple hours digging in to my system, trying to investigate why Nvidia, lshw, and lspci all listed a card on that PCI bus, but F@h didn't. Then I realized my mistake, fetched GPUs.txt (which didn't exist on my system), the restarted F@h. Low and behold, the 970 was recognized.


Did your fah log show the attempts to download the file and fail, or that it didn't try at all?
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

DocJonz
Posts: 357
Joined: Thu Dec 06, 2007 6:31 pm
Hardware configuration: 1. Farm1: i7 930, ASUS P6TD X58, 2x GTX 1070, Ubuntu 16.04
2. Farm2: i7 930, ASUS P6TD X58, 2x GTX 1070, Ubuntu 16.04
3. Farm3: i7 4790K, ASUS Z97 Pro, 2x GTX 1070, Ubuntu 16.04
4. Study: i7 3930k, ASUS Sabertooth X79, 2x GTX 1080, Ubuntu 16.04
Location: United Kingdom
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by DocJonz » Sat Feb 28, 2015 6:24 pm

bruce wrote:The package you're proposing is already present in v7.4.4 but it doesn't always work. In many cases, FAHClient.exe starts up before the internet connection is established ... checks for an update (which fails) ... and goes on to initialize folding. I'll bet that a sudo /etc/init.d/FAHClient restart would have performed the update for you (assuming you waited until network initialization had completed).

The connection to the internet was active before installing FAHClient.
I've attached the initial log which defaulted to the CPU slot only (even when the installation option was set to 'Full') because it did not recognise the GPU's, and no GPUs.txt file was present in the Folding directory. (Out of interest, what does the output line in the log look like to indicate that it tried to download the GPUs.txt file?)

Code: Select all

*********************** Log Started 2015-02-26T22:48:50Z ***********************
22:48:50:************************* Folding@home Client *************************
22:48:50:    Website: http://folding.stanford.edu/
22:48:50:  Copyright: (c) 2009-2014 Stanford University
22:48:50:     Author: Joseph Coffland <joseph@cauldrondevelopment.com>
22:48:50:       Args: --child --lifeline 3646 /etc/fahclient/config.xml --run-as
22:48:50:             fahclient --pid-file=/var/run/fahclient.pid --daemon
22:48:50:     Config: /etc/fahclient/config.xml
22:48:50:******************************** Build ********************************
22:48:50:    Version: 7.4.4
22:48:50:       Date: Mar 4 2014
22:48:50:       Time: 12:02:38
22:48:50:    SVN Rev: 4130
22:48:50:     Branch: fah/trunk/client
22:48:50:   Compiler: GNU 4.4.7
22:48:50:    Options: -std=gnu++98 -O3 -funroll-loops -mfpmath=sse -ffast-math
22:48:50:             -fno-unsafe-math-optimizations -msse2
22:48:50:   Platform: linux2 3.2.0-1-amd64
22:48:50:       Bits: 64
22:48:50:       Mode: Release
22:48:50:******************************* System ********************************
22:48:50:        CPU: Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz
22:48:50:     CPU ID: GenuineIntel Family 6 Model 26 Stepping 5
22:48:50:       CPUs: 8
22:48:50:     Memory: 5.82GiB
22:48:50:Free Memory: 4.16GiB
22:48:50:    Threads: POSIX_THREADS
22:48:50: OS Version: 3.16
22:48:50:Has Battery: false
22:48:50: On Battery: false
22:48:50: UTC Offset: 0
22:48:50:        PID: 3648
22:48:50:        CWD: /var/lib/fahclient
22:48:50:         OS: Linux 3.16.0-31-generic x86_64
22:48:50:    OS Arch: AMD64
22:48:50:       GPUs: 0
22:48:50:       CUDA: 5.2
22:48:50:CUDA Driver: 7000
22:48:50:***********************************************************************
22:48:50:<config>
22:48:50:  <!-- Client Control -->
22:48:50:  <fold-anon v='true'/>
22:48:50:
22:48:50:  <!-- Folding Slot Configuration -->
22:48:50:  <gpu v='false'/>
22:48:50:
22:48:50:  <!-- Slot Control -->
22:48:50:  <power v='full'/>
22:48:50:
22:48:50:  <!-- User Information -->
22:48:50:  <passkey v='********************************'/>
22:48:50:  <team v='35947'/>
22:48:50:  <user v='DocJonz'/>
22:48:50:
22:48:50:  <!-- Folding Slots -->
22:48:50:</config>
22:48:50:Switching to user fahclient
22:48:50:Trying to access database...
22:48:50:Successfully acquired database lock
22:48:50:FS00:Set client configured
22:48:50:Enabled folding slot 00: READY cpu:8
22:48:51:WU00:FS00:Connecting to 171.67.108.200:8080
22:48:52:WU00:FS00:Connecting to 171.67.108.200:8080
22:48:53:WU00:FS00:Assigned to work server 171.64.65.124
22:48:53:WU00:FS00:Requesting new work unit for slot 00: READY cpu:8 from 171.64.65.124
22:48:53:WU00:FS00:Connecting to 171.64.65.124:8080
22:48:54:WU00:FS00:Downloading 910.49KiB
22:48:55:WU00:FS00:Download complete
22:48:55:WU00:FS00:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:9013 run:61 clone:5 gen:62 core:0xa4 unit:0x0000004a664f2de4548afb3400cf1f6e
22:48:56:WU00:FS00:Downloading core from http://web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah
22:48:56:WU00:FS00:Connecting to web.stanford.edu:80
22:48:56:WU00:FS00:FahCore a4: Downloading 2.56MiB
22:49:02:WU00:FS00:FahCore a4: 24.42%
22:49:07:WU00:FS00:FahCore a4: Download complete
22:49:07:WU00:FS00:Valid core signature
22:49:07:WU00:FS00:Unpacked 5.98MiB to cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4
22:49:07:WU00:FS00:Starting
22:49:07:WU00:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/web.stanford.edu/~pande/Linux/AMD64/Core_a4.fah/FahCore_a4 -dir 00 -suffix 01 -version 704 -lifeline 3648 -checkpoint 15 -np 8
22:49:07:WU00:FS00:Started FahCore on PID 3864
22:49:07:WU00:FS00:Core PID:3868
22:49:07:WU00:FS00:FahCore 0xa4 started
22:49:08:WU00:FS00:0xa4:
22:49:08:WU00:FS00:0xa4:*------------------------------*
22:49:08:WU00:FS00:0xa4:Folding@Home Gromacs GB Core
22:49:08:WU00:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
22:49:08:WU00:FS00:0xa4:
22:49:08:WU00:FS00:0xa4:Preparing to commence simulation
22:49:08:WU00:FS00:0xa4:- Looking at optimizations...
22:49:08:WU00:FS00:0xa4:- Created dyn
22:49:08:WU00:FS00:0xa4:- Files status OK
22:49:08:WU00:FS00:0xa4:- Expanded 931834 -> 1546812 (decompressed 165.9 percent)
22:49:08:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=931834 data_size=1546812, decompressed_data_size=1546812 diff=0
22:49:08:WU00:FS00:0xa4:- Digital signature verified
22:49:08:WU00:FS00:0xa4:
22:49:08:WU00:FS00:0xa4:Project: 9013 (Run 61, Clone 5, Gen 62)
22:49:08:WU00:FS00:0xa4:
22:49:08:WU00:FS00:0xa4:Assembly optimizations on if available.
22:49:08:WU00:FS00:0xa4:Entering M.D.
22:49:14:WU00:FS00:0xa4:Completed 0 out of 250000 steps  (0%)

gwildperson
Posts: 726
Joined: Tue Dec 04, 2007 8:36 pm

Re: Tips for installing Nvidia .run files in Linux

Post by gwildperson » Mon Mar 02, 2015 6:29 pm

DocJonz wrote:(Out of interest, what does the output line in the log look like to indicate that it tried to download the GPUs.txt file?)


The only time I ever saw a message was when the output was directed to a screen. I think the message might be issued before the messages are being captured to log.txt.

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by 7im » Mon Mar 02, 2015 6:52 pm

Unfortunately, I could only find examples where the attempt failed.

16:24:11:Connecting to assign-GPU.stanford.edu:80
16:24:12:WARNING:Attempting to update GPUs.txt from assign-GPU.stanford.edu:80: Failed to read stream

It may not be logged since everyone runs at verbosity 3 by default, or it may not be logged at all when successful.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by 7im » Mon Mar 02, 2015 7:20 pm

How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

Adam_Ford
Posts: 16
Joined: Sun Nov 18, 2012 3:09 am

Re: Tips for installing Nvidia .run files in Linux

Post by Adam_Ford » Mon Mar 02, 2015 7:48 pm

05:52:56:Connecting to assign-GPU.stanford.edu:80
05:52:57:Updated GPUs.txt

is what a successful download looks like it downloaded after i changed gpus to true under extra client options
Image

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: Tips for installing Nvidia .run files in Linux

Post by 7im » Mon Mar 02, 2015 9:22 pm

Rats. Did a google search, and found some of those examples.

I'll have to revise the ticket to whatever the real problem is. I wonder if gpu=true is not getting set correctly by the installer in Linux?

Next failed install, we'll have to try that trick.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

davidcoton
Posts: 940
Joined: Wed Nov 05, 2008 3:19 pm
Location: Cambridge, UK

Re: Tips for installing Nvidia .run files in Linux

Post by davidcoton » Mon Mar 02, 2015 11:21 pm

I just checked extra client options on my Linux folding PC. "GPU false" ! :eo Yes, it does have a working GPU slot.

Entry not present on Windows, whether or not a GPU folding slot is installed.

EDIT: Presumably this is not the same as GPU-enabled, but my search-fu has deserted me and I can't find any documentation for the GPU option flag
Image

Post Reply

Return to “Problems with NVidia drivers”