HELP, noob tries to install F@H on Xubuntu and fails

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Post Reply
antropofob
Posts: 57
Joined: Mon Aug 22, 2011 8:03 am

HELP, noob tries to install F@H on Xubuntu and fails

Post by antropofob » Tue Oct 04, 2016 4:40 pm

Greetings,
I have a few problems re: installing F@H on Xubuntu and reading some threads I see I am not the only one.
Just like Bruce viewtopic.php?p=288311#p288311 I failed in installation of Fahcontrol, although Fahcore install went ok.
Now I forced to control folding through web browser. But it does fold, although CPU only.
I plan to buy an 1060 these days and reading threads like
viewtopic.php?f=80&t=29125 (it seems there are good and bad drivers) and viewtopic.php?p=288311#p288311 (it seems there are good and bad repositories)I am starting to think maybe I should just give up on this Linux thing.
Is there an guide how to do these things the right way?
Which drivers to use? And using which repo?
Thanks.

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by 7im » Tue Oct 04, 2016 5:20 pm

Then you also read where using GDEBI to install the fah client packages is successful in the newer versions of *Ubuntu. How did that work for you? Also, what version of Xubuntu is this?
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

antropofob
Posts: 57
Joined: Mon Aug 22, 2011 8:03 am

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by antropofob » Tue Oct 04, 2016 6:15 pm

Its newest Xubuntu.
So, GDEBI is way to go?
And then follow instructions posted here http://www.omgubuntu.co.uk/2015/08/ubun ... for-action
Bruce says
If you get your NVidia drivers from the xorg-edgers ppa they will include OpenCL and CUDA. If you get them from the drivers ppa, they will exclude OpenCL.
I will be folding on GPU only, so no problem using "drivers ppa"?
And should I be using newest drivers for 1060?
Also I read somewhere that Noveau or whatsit-called should be removed before installing proprietary Nvidia drivers?
What else could go wrong?
I will not give up!
Just got a little scared of all the CLI :-)
Everybody says "no more CLI on Linux", but I guess thats only for basic use.

7im
Posts: 14648
Joined: Thu Nov 29, 2007 4:30 pm
Hardware configuration: Intel i7-4770K @ 4.5 GHz, 16 GB DDR3-2133 Corsair Vengence (black/red), EVGA GTX 760 @ 1200 MHz, on an Asus Maximus VI Hero MB (black/red), in a blacked out Antec P280 Tower, with a Xigmatek Night Hawk (black) HSF, Seasonic 760w Platinum (black case, sleeves, wires), 4 SilenX 120mm Case fans with silicon fan gaskets and silicon mounts (all black), a 512GB Samsung SSD (black), and a 2TB Black Western Digital HD (silver/black).
Location: Arizona
Contact:

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by 7im » Tue Oct 04, 2016 7:13 pm

No, those PPA driver instructions are incomplete, hence the problem where OpenCL does not get installed, and the client won't run without the OpenCL portion of the driver, and so everyone says the PPA is bantha poodoo.

They leave out libcuda1-355 and nvidia-opencl-icd-355 (however, the sudo apt-get install nvidia-355 process does suggest installing those, just that most people don't follow that suggestion)

The comments below that article you linked also say this driver version doesn't work with 16.xx versions.

This comment might also be a good suggestion...
STOP!

Ok, the easiest way to utilise this awesome resource (no more plymouth splash issues or Xorg setups) is to add the PPA as directed above, run sudo apt-get update then CLOSE the terminal.

Now, open the dash, search 'Software', click Software & Updates, then select the Additional Drivers Tab. Allow the interface to finish searching, then you will be presented with a list of all available and compatible NVIDIA driver versions. Select the highest number for the latest revision and click Apply Changes.

Done.

If you get issues, I would guess (but havent had to try yet) that you should go back to the Additional Drivers tab and choose the Noveu drivers, restart, then select a slightly older revision.
That way you get to pick a little more current driver.
How to provide enough information to get helpful support
Tell me and I forget. Teach me and I remember. Involve me and I learn.

davidcoton
Posts: 940
Joined: Wed Nov 05, 2008 3:19 pm
Location: Cambridge, UK

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by davidcoton » Tue Oct 04, 2016 7:52 pm

Yes, there is a problem with drivers ppa or any other source that exclude OpenCL. OpenCL is essential for GPU folding.
Yes, newest drivers will support 1060. Someone may know if a slightly older version gives better ppd, but latest is a good starting point.
You will need to remove and blacklist Nouveau drivers. There's a couple of posts somewhere with step by step instructions for installing on Ubuntu, yours should be near enough the same.
When you get stuck, someone here will probably know what to do.
Image

antropofob
Posts: 57
Joined: Mon Aug 22, 2011 8:03 am

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by antropofob » Thu Oct 06, 2016 5:18 pm

Gave up, installed Windows 7, after dozen mouse clicks have GPU folding up and running on 1060 and Pentium 4.
Core 21 is using 50% of my CPU :-)

Eeyore888
Posts: 1
Joined: Sat Nov 19, 2016 7:24 am

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by Eeyore888 » Sat Nov 19, 2016 7:32 am

If you're running 16.04, then you need to install the Python support for folding at home control to work.

Follow this:

Code: Select all

wget http://launchpadlibrarian.net/109052...1.0.15_all.deb
Then

Code: Select all

sudo dpkg -i python-support_1.0.15_all.deb

erikv85
Posts: 1
Joined: Tue Apr 04, 2017 8:20 pm

Re: HELP, noob tries to install F@H on Xubuntu and fails

Post by erikv85 » Tue Apr 04, 2017 8:21 pm

Eeyore888 wrote:If you're running 16.04, then you need to install the Python support for folding at home control to work.

Follow this:

Code: Select all

wget http://launchpadlibrarian.net/109052...1.0.15_all.deb
Then

Code: Select all

sudo dpkg -i python-support_1.0.15_all.deb
The launchpad link is incomplete or at least doesn't work.


Post Reply

Return to “Problems with NVidia drivers”