1070 Q-Max BAD_WORK_UNIT

It seems that a lot of GPU problems revolve around specific versions of drivers. Though NVidia has their own support structure, you can often learn from information reported by others who fold.

Moderators: Site Moderators, PandeGroup

Post Reply
Jility
Posts: 2
Joined: Sat Jun 22, 2019 10:24 pm

1070 Q-Max BAD_WORK_UNIT

Post by Jility » Sat Jun 22, 2019 10:46 pm

Hi, I am fairly new to FAH, and I am having problems setting up a reliable system for folding. I have a Gigabyte Aero 15xv8 with iGPU and Nvidia GPU. The Nvidia driver is 430.63 (Studio) and I have set FAH to always use Nvidia GPU in Nvidia system settings.
The problem is, that sometimes there are so many BAD_WORK_UNIT that it stops trying and give me a failed message.
Is this a common issues or does anybody know what causes this issue an how to get around it? Maybe changing opencl-index oder cuda-index? Any help would be appreciated.

Code: Select all

22:10:19:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:27:WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo

Code: Select all

22:10:03:******************************** Build ********************************
22:10:03:        Version: 7.5.1
22:10:03:           Date: May 11 2018
22:10:03:           Time: 13:06:32
22:10:03:     Repository: Git
22:10:03:       Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
22:10:03:         Branch: master
22:10:03:       Compiler: Visual C++ 2008
22:10:03:        Options: /TP /nologo /EHa /wd4297 /wd4103 /Ox /MT
22:10:03:       Platform: win32 10
22:10:03:           Bits: 32
22:10:03:           Mode: Release
22:10:03:******************************* System ********************************
22:10:03:            CPU: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz
22:10:03:         CPU ID: GenuineIntel Family 6 Model 158 Stepping 10
22:10:03:           CPUs: 12
22:10:03:         Memory: 23.86GiB
22:10:03:    Free Memory: 21.70GiB
22:10:03:        Threads: WINDOWS_THREADS
22:10:03:     OS Version: 6.2
22:10:03:    Has Battery: true
22:10:03:     On Battery: false
22:10:03:     UTC Offset: 2
22:10:03:            PID: 3548
22:10:03:            CWD: C:\Users\AERO\AppData\Roaming\FAHClient
22:10:03:             OS: Windows 10 Enterprise
22:10:03:        OS Arch: AMD64
22:10:03:           GPUs: 1
22:10:03:          GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:5 GP104M [GeForce GTX 1070 Mobile]
22:10:03:  CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:10.2
22:10:03:OpenCL Device 0: Platform:0 Device:0 Bus:NA Slot:NA Compute:2.1 Driver:25.20
22:10:03:OpenCL Device 2: Platform:1 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:430.63
22:10:03:  Win32 Service: false
22:10:03:***********************************************************************
22:10:03:<config>
22:10:03:  <service-description v='Folding@home Client'/>
22:10:03:  <service-restart v='true'/>
22:10:03:  <service-restart-delay v='5000'/>
22:10:03:
22:10:03:  <!-- Client Control -->
22:10:03:  <client-threads v='6'/>
22:10:03:  <cycle-rate v='4'/>
22:10:03:  <cycles v='-1'/>
22:10:03:  <data-directory v='.'/>
22:10:03:  <disable-sleep-when-active v='true'/>
22:10:03:  <exec-directory v='C:\Program Files (x86)\FAHClient'/>
22:10:03:  <exit-when-done v='false'/>
22:10:03:  <fold-anon v='false'/>
22:10:03:  <open-web-control v='false'/>
22:10:03:
22:10:03:  <!-- Configuration -->
22:10:03:  <config-rotate v='true'/>
22:10:03:  <config-rotate-dir v='configs'/>
22:10:03:  <config-rotate-max v='16'/>
22:10:03:
22:10:03:  <!-- Debugging -->
22:10:03:  <assignment-servers>
22:10:03:    assign1.foldingathome.org:8080 assign2.foldingathome.org:80
22:10:03:  </assignment-servers>
22:10:03:  <auth-as v='true'/>
22:10:03:  <capture-directory v='capture'/>
22:10:03:  <capture-on-error v='false'/>
22:10:03:  <capture-packets v='false'/>
22:10:03:  <capture-requests v='false'/>
22:10:03:  <capture-responses v='false'/>
22:10:03:  <capture-sockets v='false'/>
22:10:03:  <core-exec v='FahCore_$type'/>
22:10:03:  <core-wrapper-exec v='FAHCoreWrapper'/>
22:10:03:  <debug-sockets v='false'/>
22:10:03:  <exception-locations v='true'/>
22:10:03:  <stack-traces v='false'/>
22:10:03:
22:10:03:  <!-- Error Handling -->
22:10:03:  <max-slot-errors v='10'/>
22:10:03:  <max-unit-errors v='5'/>
22:10:03:
22:10:03:  <!-- Folding Core -->
22:10:03:  <checkpoint v='30'/>
22:10:03:  <core-dir v='cores'/>
22:10:03:  <core-priority v='idle'/>
22:10:03:  <cpu-affinity v='false'/>
22:10:03:  <cpu-usage v='100'/>
22:10:03:  <gpu-usage v='100'/>
22:10:03:  <no-assembly v='false'/>
22:10:03:
22:10:03:  <!-- Folding Slot Configuration -->
22:10:03:  <cause v='ANY'/>
22:10:03:  <client-subtype v='STDCLI'/>
22:10:03:  <client-type v='normal'/>
22:10:03:  <cpu-species v='X86_PENTIUM_II'/>
22:10:03:  <cpu-type v='AMD64'/>
22:10:03:  <cpus v='-1'/>
22:10:03:  <disable-viz v='false'/>
22:10:03:  <gpu v='true'/>
22:10:03:  <max-packet-size v='normal'/>
22:10:03:  <os-species v='WIN_8'/>
22:10:03:  <os-type v='WIN32'/>
22:10:03:  <project-key v='0'/>
22:10:03:  <smp v='true'/>
22:10:03:
22:10:03:  <!-- GUI -->
22:10:03:  <gui-enabled v='true'/>
22:10:03:
22:10:03:  <!-- HTTP Server -->
22:10:03:  <allow v='127.0.0.1'/>
22:10:03:  <connection-timeout v='60'/>
22:10:03:  <deny v='0/0'/>
22:10:03:  <http-addresses v='0:7396'/>
22:10:03:  <https-addresses v=''/>
22:10:03:  <max-connect-time v='900'/>
22:10:03:  <max-connections v='800'/>
22:10:03:  <max-request-length v='52428800'/>
22:10:03:  <min-connect-time v='300'/>
22:10:03:
22:10:03:  <!-- Logging -->
22:10:03:  <log v='log.txt'/>
22:10:03:  <log-color v='false'/>
22:10:03:  <log-crlf v='true'/>
22:10:03:  <log-date v='false'/>
22:10:03:  <log-date-periodically v='21600'/>
22:10:03:  <log-domain v='false'/>
22:10:03:  <log-header v='true'/>
22:10:03:  <log-level v='true'/>
22:10:03:  <log-no-info-header v='true'/>
22:10:03:  <log-redirect v='false'/>
22:10:03:  <log-rotate v='true'/>
22:10:03:  <log-rotate-dir v='logs'/>
22:10:03:  <log-rotate-max v='16'/>
22:10:03:  <log-short-level v='false'/>
22:10:03:  <log-simple-domains v='true'/>
22:10:03:  <log-thread-id v='false'/>
22:10:03:  <log-thread-prefix v='true'/>
22:10:03:  <log-time v='true'/>
22:10:03:  <log-to-screen v='true'/>
22:10:03:  <log-truncate v='false'/>
22:10:03:  <verbosity v='5'/>
22:10:03:
22:10:03:  <!-- Network -->
22:10:03:  <proxy v=':8080'/>
22:10:03:  <proxy-enable v='false'/>
22:10:03:  <proxy-pass v=''/>
22:10:03:  <proxy-user v=''/>
22:10:03:
22:10:03:  <!-- Process Control -->
22:10:03:  <child v='false'/>
22:10:03:  <daemon v='false'/>
22:10:03:  <pid v='false'/>
22:10:03:  <pid-file v='Folding@home Client.pid'/>
22:10:03:  <respawn v='false'/>
22:10:03:  <service v='false'/>
22:10:03:
22:10:03:  <!-- Remote Command Server -->
22:10:03:  <command-address v='0.0.0.0'/>
22:10:03:  <command-allow-no-pass v='127.0.0.1'/>
22:10:03:  <command-deny-no-pass v='0/0'/>
22:10:03:  <command-enable v='true'/>
22:10:03:  <command-port v='36330'/>
22:10:03:
22:10:03:  <!-- Slot Control -->
22:10:03:  <idle v='false'/>
22:10:03:  <max-shutdown-wait v='60'/>
22:10:03:  <pause-on-battery v='true'/>
22:10:03:  <pause-on-start v='false'/>
22:10:03:  <paused v='false'/>
22:10:03:  <power v='full'/>
22:10:03:
22:10:03:  <!-- User Information -->
22:10:03:  <machine-id v='0'/>
22:10:03:  <passkey v='********************************'/>
22:10:03:  <team v='234980'/>
22:10:03:  <user v='1jxk3yjanrpy'/>
22:10:03:
22:10:03:  <!-- Web Server -->
22:10:03:  <web-allow v='127.0.0.1'/>
22:10:03:  <web-deny v='0/0'/>
22:10:03:  <web-enable v='true'/>
22:10:03:
22:10:03:  <!-- Web Server Sessions -->
22:10:03:  <session-cookie v='sid'/>
22:10:03:  <session-lifetime v='86400'/>
22:10:03:  <session-timeout v='3600'/>
22:10:03:
22:10:03:  <!-- Work Unit Control -->
22:10:03:  <dump-after-deadline v='true'/>
22:10:03:  <max-queue v='16'/>
22:10:03:  <max-units v='0'/>
22:10:03:  <next-unit-percentage v='99'/>
22:10:03:  <stall-detection-enabled v='false'/>
22:10:03:  <stall-percent v='5'/>
22:10:03:  <stall-timeout v='1800'/>
22:10:03:
22:10:03:  <!-- Folding Slots -->
22:10:03:  <slot id='0' type='CPU'/>
22:10:03:  <slot id='1' type='GPU'/>
22:10:03:</config>
22:10:03:Trying to access database...
22:10:03:Successfully acquired database lock
22:10:03:Enabled folding slot 00: READY cpu:11
22:10:03:Enabled folding slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile]
22:10:03:WARNING:WU02:No longer matches Slot 1's configuration, migrating to FS00
22:10:03:ERROR:Exception: Unit not found
22:10:03:Started thread 4 on PID 3548
22:10:03:Started thread 9 on PID 3548
22:10:03:Started thread 6 on PID 3548
22:10:03:Started thread 5 on PID 3548
22:10:03:Started thread 7 on PID 3548
22:10:03:Started thread 8 on PID 3548
22:10:03:WU01:FS00:Starting
22:10:03:WARNING:WU01:FS00:AS lowered CPUs from 11 to 10
22:10:03:WU01:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/Core_a4.fah/FahCore_a4.exe -dir 01 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -np 10
22:10:03:WU01:FS00:Started FahCore on PID 7988
22:10:03:Started thread 10 on PID 3548
22:10:03:WU01:FS00:Core PID:3148
22:10:03:WU01:FS00:FahCore 0xa4 started
22:10:03:WU00:FS01:Connecting to 65.254.110.245:8080
22:10:03:WU01:FS00:0xa4:
22:10:03:WU01:FS00:0xa4:*------------------------------*
22:10:03:WU01:FS00:0xa4:Folding@Home Gromacs GB Core
22:10:03:WU01:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
22:10:03:WU01:FS00:0xa4:
22:10:03:WU01:FS00:0xa4:Preparing to commence simulation
22:10:03:WU01:FS00:0xa4:- Looking at optimizations...
22:10:03:WU01:FS00:0xa4:- Files status OK
22:10:03:WU01:FS00:0xa4:- Expanded 826235 -> 1403472 (decompressed 169.8 percent)
22:10:03:WU01:FS00:0xa4:Called DecompressByteArray: compressed_data_size=826235 data_size=1403472, decompressed_data_size=1403472 diff=0
22:10:03:WU01:FS00:0xa4:- Digital signature verified
22:10:03:WU01:FS00:0xa4:
22:10:03:WU01:FS00:0xa4:Project: 9037 (Run 288, Clone 2, Gen 2182)
22:10:03:WU01:FS00:0xa4:
22:10:03:WU01:FS00:0xa4:Assembly optimizations on if available.
22:10:03:WU01:FS00:0xa4:Entering M.D.
22:10:04:WU00:FS01:Assigned to work server 155.247.166.220
22:10:04:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:04:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:06:WU00:FS01:Downloading 501.35KiB
22:10:07:WU00:FS01:Download complete
22:10:07:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:14163 run:19 clone:85 gen:18 core:0x21 unit:0x0000001a0002894c5c38bec0ab2b0909
22:10:07:WU00:FS01:Starting
22:10:07:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:10:07:WU00:FS01:Started FahCore on PID 8596
22:10:07:Started thread 11 on PID 3548
22:10:07:WU00:FS01:Core PID:9752
22:10:07:WU00:FS01:FahCore 0x21 started
22:10:07:WU00:FS01:0x21:*********************** Log Started 2019-06-22T22:10:07Z ***********************
22:10:07:WU00:FS01:0x21:Project: 14163 (Run 19, Clone 85, Gen 18)
22:10:07:WU00:FS01:0x21:Unit: 0x0000001a0002894c5c38bec0ab2b0909
22:10:07:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:10:07:WU00:FS01:0x21:Machine: 1
22:10:07:WU00:FS01:0x21:Reading tar file core.xml
22:10:07:WU00:FS01:0x21:Reading tar file integrator.xml
22:10:07:WU00:FS01:0x21:Reading tar file state.xml
22:10:07:WU00:FS01:0x21:Reading tar file system.xml
22:10:07:WU00:FS01:0x21:Digital signatures verified
22:10:07:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:10:07:WU00:FS01:0x21:Version 0.0.18
22:10:08:WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:10:08:WU00:FS01:0x21:Saving result file logfile_01.txt
22:10:08:WU00:FS01:0x21:Saving result file log.txt
22:10:08:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:10:09:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:09:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14163 run:19 clone:85 gen:18 core:0x21 unit:0x0000001a0002894c5c38bec0ab2b0909
22:10:09:WU00:FS01:Uploading 2.39KiB to 155.247.166.220
22:10:09:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:09:WU01:FS00:0xa4:Using Gromacs checkpoints
22:10:09:WU01:FS00:0xa4:Mapping NT from 10 to 10 
22:10:09:WU01:FS00:0xa4:Resuming from checkpoint
22:10:09:WU01:FS00:0xa4:Verified 01/wudata_01.log
22:10:09:WU01:FS00:0xa4:Verified 01/wudata_01.trr
22:10:09:WU01:FS00:0xa4:Verified 01/wudata_01.xtc
22:10:09:WU01:FS00:0xa4:Verified 01/wudata_01.edr
22:10:09:WU00:FS01:Upload complete
22:10:09:WU00:FS01:Server responded WORK_ACK (400)
22:10:09:WU00:FS01:Cleaning up
22:10:09:WU02:FS01:Connecting to 65.254.110.245:8080
22:10:09:WU01:FS00:0xa4:Completed 99815 out of 250000 steps  (39%)
22:10:10:WU02:FS01:Assigned to work server 155.247.166.220
22:10:10:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:10:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:12:WU02:FS01:Downloading 838.46KiB
22:10:13:WU01:FS00:0xa4:Completed 100000 out of 250000 steps  (40%)
22:10:13:Started thread 12 on PID 3548
22:10:15:WU02:FS01:Download complete
22:10:15:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:14166 run:3 clone:61 gen:134 core:0x21 unit:0x000000c40002894c5c38bfff0a5e9a02
22:10:15:WU02:FS01:Starting
22:10:15:WU02:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 02 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:10:15:WU02:FS01:Started FahCore on PID 6464
22:10:15:Started thread 13 on PID 3548
22:10:15:WU02:FS01:Core PID:10012
22:10:15:WU02:FS01:FahCore 0x21 started
22:10:16:WU02:FS01:0x21:*********************** Log Started 2019-06-22T22:10:15Z ***********************
22:10:16:WU02:FS01:0x21:Project: 14166 (Run 3, Clone 61, Gen 134)
22:10:16:WU02:FS01:0x21:Unit: 0x000000c40002894c5c38bfff0a5e9a02
22:10:16:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:10:16:WU02:FS01:0x21:Machine: 1
22:10:16:WU02:FS01:0x21:Reading tar file core.xml
22:10:16:WU02:FS01:0x21:Reading tar file integrator.xml
22:10:16:WU02:FS01:0x21:Reading tar file state.xml
22:10:16:WU02:FS01:0x21:Reading tar file system.xml
22:10:16:WU02:FS01:0x21:Digital signatures verified
22:10:16:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:10:16:WU02:FS01:0x21:Version 0.0.18
22:10:17:WU02:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:10:17:WU02:FS01:0x21:Saving result file logfile_01.txt
22:10:17:WU02:FS01:0x21:Saving result file log.txt
22:10:17:WU02:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:10:19:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:19:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:14166 run:3 clone:61 gen:134 core:0x21 unit:0x000000c40002894c5c38bfff0a5e9a02
22:10:19:WU02:FS01:Uploading 2.37KiB to 155.247.166.220
22:10:19:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:19:WU00:FS01:Connecting to 65.254.110.245:8080
22:10:19:WU02:FS01:Upload complete
22:10:19:WU02:FS01:Server responded WORK_ACK (400)
22:10:19:WU02:FS01:Cleaning up
22:10:20:WU00:FS01:Assigned to work server 155.247.166.220
22:10:20:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:20:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:21:WU00:FS01:Downloading 501.65KiB
22:10:25:WU00:FS01:Download complete
22:10:25:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:14163 run:16 clone:45 gen:240 core:0x21 unit:0x0000013e0002894c5c38be9dbc8dba80
22:10:25:WU00:FS01:Starting
22:10:25:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:10:25:WU00:FS01:Started FahCore on PID 9448
22:10:25:Started thread 14 on PID 3548
22:10:25:WU00:FS01:Core PID:9896
22:10:25:WU00:FS01:FahCore 0x21 started
22:10:25:WU00:FS01:0x21:*********************** Log Started 2019-06-22T22:10:25Z ***********************
22:10:25:WU00:FS01:0x21:Project: 14163 (Run 16, Clone 45, Gen 240)
22:10:25:WU00:FS01:0x21:Unit: 0x0000013e0002894c5c38be9dbc8dba80
22:10:25:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:10:25:WU00:FS01:0x21:Machine: 1
22:10:25:WU00:FS01:0x21:Reading tar file core.xml
22:10:25:WU00:FS01:0x21:Reading tar file integrator.xml
22:10:25:WU00:FS01:0x21:Reading tar file state.xml
22:10:25:WU00:FS01:0x21:Reading tar file system.xml
22:10:25:WU00:FS01:0x21:Digital signatures verified
22:10:25:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:10:25:WU00:FS01:0x21:Version 0.0.18
22:10:27:WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:10:27:WU00:FS01:0x21:Saving result file logfile_01.txt
22:10:27:WU00:FS01:0x21:Saving result file log.txt
22:10:27:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:10:28:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:28:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14163 run:16 clone:45 gen:240 core:0x21 unit:0x0000013e0002894c5c38be9dbc8dba80
22:10:28:WU00:FS01:Uploading 2.38KiB to 155.247.166.220
22:10:28:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:28:WU00:FS01:Upload complete
22:10:28:WU00:FS01:Server responded WORK_ACK (400)
22:10:28:WU00:FS01:Cleaning up
22:10:28:WU02:FS01:Connecting to 65.254.110.245:8080
22:10:29:WU02:FS01:Assigned to work server 155.247.166.220
22:10:29:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:29:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:31:WU02:FS01:Downloading 836.66KiB
22:10:35:WU02:FS01:Download complete
22:10:35:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:14166 run:10 clone:22 gen:49 core:0x21 unit:0x0000004b0002894c5c38c0528059fdc9
22:10:35:WU02:FS01:Starting
22:10:35:WU02:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 02 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:10:35:WU02:FS01:Started FahCore on PID 8560
22:10:35:Started thread 15 on PID 3548
22:10:35:WU02:FS01:Core PID:1052
22:10:35:WU02:FS01:FahCore 0x21 started
22:10:35:WU02:FS01:0x21:*********************** Log Started 2019-06-22T22:10:35Z ***********************
22:10:35:WU02:FS01:0x21:Project: 14166 (Run 10, Clone 22, Gen 49)
22:10:35:WU02:FS01:0x21:Unit: 0x0000004b0002894c5c38c0528059fdc9
22:10:35:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:10:35:WU02:FS01:0x21:Machine: 1
22:10:35:WU02:FS01:0x21:Reading tar file core.xml
22:10:35:WU02:FS01:0x21:Reading tar file integrator.xml
22:10:35:WU02:FS01:0x21:Reading tar file state.xml
22:10:35:WU02:FS01:0x21:Reading tar file system.xml
22:10:35:WU02:FS01:0x21:Digital signatures verified
22:10:35:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:10:35:WU02:FS01:0x21:Version 0.0.18
22:10:38:WU02:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:10:38:WU02:FS01:0x21:Saving result file logfile_01.txt
22:10:38:WU02:FS01:0x21:Saving result file log.txt
22:10:38:WU02:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:10:38:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:38:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:14166 run:10 clone:22 gen:49 core:0x21 unit:0x0000004b0002894c5c38c0528059fdc9
22:10:38:WU02:FS01:Uploading 2.40KiB to 155.247.166.220
22:10:38:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:39:WU02:FS01:Upload complete
22:10:39:WU02:FS01:Server responded WORK_ACK (400)
22:10:39:WU02:FS01:Cleaning up
22:10:39:WU00:FS01:Connecting to 65.254.110.245:8080
22:10:40:WU00:FS01:Assigned to work server 155.247.166.220
22:10:40:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:40:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:42:WU00:FS01:Downloading 838.96KiB
22:10:48:WU00:FS01:Download 68.66%
22:10:49:WU00:FS01:Download complete
22:10:49:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:14166 run:0 clone:69 gen:238 core:0x21 unit:0x000001580002894c5c38bfeb9f033980
22:10:49:WU00:FS01:Starting
22:10:49:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:10:49:WU00:FS01:Started FahCore on PID 7192
22:10:49:Started thread 16 on PID 3548
22:10:49:WU00:FS01:Core PID:8640
22:10:49:WU00:FS01:FahCore 0x21 started
22:10:50:WU00:FS01:0x21:*********************** Log Started 2019-06-22T22:10:49Z ***********************
22:10:50:WU00:FS01:0x21:Project: 14166 (Run 0, Clone 69, Gen 238)
22:10:50:WU00:FS01:0x21:Unit: 0x000001580002894c5c38bfeb9f033980
22:10:50:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:10:50:WU00:FS01:0x21:Machine: 1
22:10:50:WU00:FS01:0x21:Reading tar file core.xml
22:10:50:WU00:FS01:0x21:Reading tar file integrator.xml
22:10:50:WU00:FS01:0x21:Reading tar file state.xml
22:10:50:WU00:FS01:0x21:Reading tar file system.xml
22:10:50:WU00:FS01:0x21:Digital signatures verified
22:10:50:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:10:50:WU00:FS01:0x21:Version 0.0.18
22:10:52:WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:10:52:WU00:FS01:0x21:Saving result file logfile_01.txt
22:10:52:WU00:FS01:0x21:Saving result file log.txt
22:10:52:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:10:53:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:10:53:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14166 run:0 clone:69 gen:238 core:0x21 unit:0x000001580002894c5c38bfeb9f033980
22:10:53:WU00:FS01:Uploading 2.36KiB to 155.247.166.220
22:10:53:WU00:FS01:Connecting to 155.247.166.220:8080
22:10:53:WU02:FS01:Connecting to 65.254.110.245:8080
22:10:53:WU00:FS01:Upload complete
22:10:53:WU00:FS01:Server responded WORK_ACK (400)
22:10:53:WU00:FS01:Cleaning up
22:10:54:WU02:FS01:Assigned to work server 155.247.166.220
22:10:54:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:54:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:54:ERROR:WU02:FS01:Exception: Server did not assign work unit
22:10:54:WU02:FS01:Connecting to 65.254.110.245:8080
22:10:55:WU02:FS01:Assigned to work server 155.247.166.220
22:10:55:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:10:55:WU02:FS01:Connecting to 155.247.166.220:8080
22:10:55:ERROR:WU02:FS01:Exception: Server did not assign work unit
22:10:59:WU01:FS00:0xa4:Completed 102500 out of 250000 steps  (41%)
22:11:46:WU01:FS00:0xa4:Completed 105000 out of 250000 steps  (42%)
22:11:55:WU02:FS01:Connecting to 65.254.110.245:8080
22:11:55:WU02:FS01:Assigned to work server 155.247.166.220
22:11:55:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:11:55:WU02:FS01:Connecting to 155.247.166.220:8080
22:11:57:WU02:FS01:Downloading 838.78KiB
22:12:03:WU02:FS01:Download 68.67%
22:12:04:WU02:FS01:Download complete
22:12:04:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:14166 run:9 clone:26 gen:183 core:0x21 unit:0x000001060002894c5c38c04888f25139
22:12:05:WU02:FS01:Starting
22:12:05:WU02:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 02 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:12:05:WU02:FS01:Started FahCore on PID 2616
22:12:05:Started thread 17 on PID 3548
22:12:05:WU02:FS01:Core PID:3000
22:12:05:WU02:FS01:FahCore 0x21 started
22:12:05:WU02:FS01:0x21:*********************** Log Started 2019-06-22T22:12:05Z ***********************
22:12:05:WU02:FS01:0x21:Project: 14166 (Run 9, Clone 26, Gen 183)
22:12:05:WU02:FS01:0x21:Unit: 0x000001060002894c5c38c04888f25139
22:12:05:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:12:05:WU02:FS01:0x21:Machine: 1
22:12:05:WU02:FS01:0x21:Reading tar file core.xml
22:12:05:WU02:FS01:0x21:Reading tar file integrator.xml
22:12:05:WU02:FS01:0x21:Reading tar file state.xml
22:12:05:WU02:FS01:0x21:Reading tar file system.xml
22:12:05:WU02:FS01:0x21:Digital signatures verified
22:12:05:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:12:05:WU02:FS01:0x21:Version 0.0.18
22:12:08:WU02:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:12:08:WU02:FS01:0x21:Saving result file logfile_01.txt
22:12:08:WU02:FS01:0x21:Saving result file log.txt
22:12:08:WU02:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:12:09:WARNING:WU02:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:12:09:WU02:FS01:Sending unit results: id:02 state:SEND error:FAULTY project:14166 run:9 clone:26 gen:183 core:0x21 unit:0x000001060002894c5c38c04888f25139
22:12:09:WU02:FS01:Uploading 2.39KiB to 155.247.166.220
22:12:09:WU02:FS01:Connecting to 155.247.166.220:8080
22:12:09:WU00:FS01:Connecting to 65.254.110.245:8080
22:12:09:WU02:FS01:Upload complete
22:12:09:WU02:FS01:Server responded WORK_ACK (400)
22:12:09:WU02:FS01:Cleaning up
22:12:09:WU00:FS01:Assigned to work server 155.247.166.220
22:12:09:WU00:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:12:09:WU00:FS01:Connecting to 155.247.166.220:8080
22:12:12:WU00:FS01:Downloading 835.31KiB
22:12:15:WU00:FS01:Download complete
22:12:15:WU00:FS01:Received Unit: id:00 state:DOWNLOAD error:NO_ERROR project:14166 run:5 clone:49 gen:115 core:0x21 unit:0x000000a60002894c5c38c00f2ca2dd7c
22:12:15:WU00:FS01:Starting
22:12:15:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:12:16:WU00:FS01:Started FahCore on PID 6724
22:12:16:Started thread 18 on PID 3548
22:12:16:WU00:FS01:Core PID:9408
22:12:16:WU00:FS01:FahCore 0x21 started
22:12:16:WU00:FS01:0x21:*********************** Log Started 2019-06-22T22:12:16Z ***********************
22:12:16:WU00:FS01:0x21:Project: 14166 (Run 5, Clone 49, Gen 115)
22:12:16:WU00:FS01:0x21:Unit: 0x000000a60002894c5c38c00f2ca2dd7c
22:12:16:WU00:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:12:16:WU00:FS01:0x21:Machine: 1
22:12:16:WU00:FS01:0x21:Reading tar file core.xml
22:12:16:WU00:FS01:0x21:Reading tar file integrator.xml
22:12:16:WU00:FS01:0x21:Reading tar file state.xml
22:12:16:WU00:FS01:0x21:Reading tar file system.xml
22:12:16:WU00:FS01:0x21:Digital signatures verified
22:12:16:WU00:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:12:16:WU00:FS01:0x21:Version 0.0.18
22:12:19:WU00:FS01:0x21:ERROR:exception: Error initializing context: clGetDeviceInfo (-5)
22:12:19:WU00:FS01:0x21:Saving result file logfile_01.txt
22:12:19:WU00:FS01:0x21:Saving result file log.txt
22:12:19:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:12:19:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)
22:12:19:WU00:FS01:Sending unit results: id:00 state:SEND error:FAULTY project:14166 run:5 clone:49 gen:115 core:0x21 unit:0x000000a60002894c5c38c00f2ca2dd7c
22:12:19:WU00:FS01:Uploading 2.40KiB to 155.247.166.220
22:12:19:WU00:FS01:Connecting to 155.247.166.220:8080
22:12:19:WU02:FS01:Connecting to 65.254.110.245:8080
22:12:19:WU00:FS01:Upload complete
22:12:19:WU00:FS01:Server responded WORK_ACK (400)
22:12:19:WU00:FS01:Cleaning up
22:12:20:WU02:FS01:Assigned to work server 155.247.166.220
22:12:20:WU02:FS01:Requesting new work unit for slot 01: READY gpu:0:GP104M [GeForce GTX 1070 Mobile] from 155.247.166.220
22:12:20:WU02:FS01:Connecting to 155.247.166.220:8080
22:12:21:WU02:FS01:Downloading 504.93KiB
22:12:24:WU02:FS01:Download complete
22:12:24:WU02:FS01:Received Unit: id:02 state:DOWNLOAD error:NO_ERROR project:14163 run:35 clone:40 gen:181 core:0x21 unit:0x000000fa0002894c5c38bf88c50959c6
22:12:24:WU02:FS01:Starting
22:12:24:WU02:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 02 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0
22:12:24:WU02:FS01:Started FahCore on PID 768
22:12:24:Started thread 19 on PID 3548
22:12:24:WU02:FS01:Core PID:3420
22:12:24:WU02:FS01:FahCore 0x21 started
22:12:25:WU02:FS01:0x21:*********************** Log Started 2019-06-22T22:12:24Z ***********************
22:12:25:WU02:FS01:0x21:Project: 14163 (Run 35, Clone 40, Gen 181)
22:12:25:WU02:FS01:0x21:Unit: 0x000000fa0002894c5c38bf88c50959c6
22:12:25:WU02:FS01:0x21:CPU: 0x00000000000000000000000000000000
22:12:25:WU02:FS01:0x21:Machine: 1
22:12:25:WU02:FS01:0x21:Reading tar file core.xml
22:12:25:WU02:FS01:0x21:Reading tar file integrator.xml
22:12:25:WU02:FS01:0x21:Reading tar file state.xml
22:12:25:WU02:FS01:0x21:Reading tar file system.xml
22:12:25:WU02:FS01:0x21:Digital signatures verified
22:12:25:WU02:FS01:0x21:Folding@home GPU Core21 Folding@home Core
22:12:25:WU02:FS01:0x21:Version 0.0.18
22:12:33:WU02:FS01:0x21:Completed 0 out of 12500000 steps (0%)
22:12:33:WU02:FS01:0x21:Temperature control disabled. Requirements: single Nvidia GPU, tmax must be < 110 and twait >= 900

JimboPalmer
Posts: 857
Joined: Mon Feb 16, 2009 4:12 am
Hardware configuration: Several dozen Core2duos and i3s at a Mental Health organization. About six i5 at home, including a GTX 1050ti GPU that does half the total points.
Location: Greenwood MS USA

Re: 1070 Q-Max BAD_WORK_UNIT

Post by JimboPalmer » Sun Jun 23, 2019 2:16 am

If you set verbosity to 3, experts may be able to see the error.

"22:10:03: <verbosity v='5'/>"
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: 1070 Q-Max BAD_WORK_UNIT

Post by bruce » Sun Jun 23, 2019 5:10 am

You probably have a feature on your motherboard which automatically switches between the iBPU and the NVidia GPU. (I have forgotten what the feature is called.) FAH does not support the iGPU so if your OS is deciding that characteristics of the graphic activity warrants switching from the NVidia to the iGPU to save power, that might be causing the problem. Disabling the iGPU entirely might help.
The Error initializing context: clGetDeviceInfo (-5) suggests that the driver has somehow changed.

Project: 14163 (Run 19, Clone 85, Gen 18) failed for you but was successfully complete by someone else.

Note that your two GPUs are
22:10:03:OpenCL Device 0: Platform:0 Device:0 Bus:NA Slot:NA Compute:2.1 Driver:25.20
22:10:03:OpenCL Device 2: Platform:1 Device:0 Bus:1 Slot:0 Compute:1.2 Driver:430.63

(based on 22:12:15:WU00:FS01:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:\Users\AERO\AppData\Roaming\FAHClient\cores/cores.foldingathome.org/Win32/AMD64/NVIDIA/Fermi/Core_21.fah/FahCore_21.exe -dir 00 -suffix 01 -version 705 -lifeline 3548 -checkpoint 30 -gpu-vendor nvidia -opencl-platform 1 -opencl-device 0 -cuda-device 0 -gpu 0)
it seems that project:14166 run:3 clone:61 gen:134 core:0x21 is being started on -opencl-device 0 -gpu 0 which is running the intel GPU driver 25.20 rather than the NVidia driver 430.63 so your statement " I have set FAH to always use Nvidia GPU in Nvidia system settings." is not true.

Jility
Posts: 2
Joined: Sat Jun 22, 2019 10:24 pm

Re: 1070 Q-Max BAD_WORK_UNIT

Post by Jility » Sun Jun 23, 2019 7:33 pm

@bruce Thanks for your information. It seems as if Nvidia system control is not as powerful as it pretends to be, or at least it does not do what it supposed to do. So I disabled the Intel HD Device and F@H seems to work as expected.

JimboPalmer
Posts: 857
Joined: Mon Feb 16, 2009 4:12 am
Hardware configuration: Several dozen Core2duos and i3s at a Mental Health organization. About six i5 at home, including a GTX 1050ti GPU that does half the total points.
Location: Greenwood MS USA

Re: 1070 Q-Max BAD_WORK_UNIT

Post by JimboPalmer » Sun Jun 23, 2019 7:39 pm

That was my experience, if it has no other choice, it behaves as desired.

(My experience was about 9 years ago on a Geforce 205, I was hoping it got better)
Tsar of all the Rushers
I tried to remain childlike, all I achieved was childish.
A friend to those who want no friends

Yavanius
Posts: 115
Joined: Thu Nov 03, 2016 4:55 am
Location: 92408

Re: 1070 Q-Max BAD_WORK_UNIT

Post by Yavanius » Fri Jun 28, 2019 12:53 am

Jility wrote:@bruce Thanks for your information. It seems as if Nvidia system control is not as powerful as it pretends to be, or at least it does not do what it supposed to do. So I disabled the Intel HD Device and F@H seems to work as expected.
I have a similar problem too, although I reported in the main client area as I didn't know it was driver related initially, and after some extended troubleshooting it seems something broke after the 417 driver. I actually have an ASUS and HP notebooks that both have this issue and both are fine as long as I don't go past the 417 driver. Trying to disable the Intel driver didn't do anything except for giving me a cruddy display.

It seems to be an nVidia issue but possibly could be related to something Microsoft is doing too although I'd rather have an older driver than rollback 5-6 months of Microsoft updates (if I could).

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: 1070 Q-Max BAD_WORK_UNIT

Post by bruce » Fri Jun 28, 2019 3:33 pm

FAH has no control over what Intel or NVidia does. If you're not happy with how they handle the drivers, that's really part of the contract between you and each of them. We only find out about issues like that when somebody (like yourself) happens to report it here -- and then we can only debug what is happening if you provide us with full information.

Post Reply

Return to “Problems with NVidia drivers”