Unable to upload project 11730 to 128.252.203.2

Moderators: Site Moderators, PandeGroup

Post Reply
FijiRed2
Posts: 5
Joined: Thu Oct 14, 2010 10:03 pm

Unable to upload project 11730 to 128.252.203.2

Post by FijiRed2 » Mon Dec 10, 2018 11:13 am

Good Evening - I have three workunits which will not upload to 128.252.203.2 All three are for Project 11730. I have restarted the PC with no joy. I have had other workunits upload to other servers successfully. Please advise how I can get these units uploaded.

10:40:58:WU02:FS00:Upload 93.17%
10:41:09:WU02:FS00:Upload 95.23%
10:41:09:WU00:FS00:Upload 91.91%
10:41:09:WU01:FS00:Upload 91.12%
10:41:17:WU02:FS00:Upload 97.28%
10:41:23:WU02:FS00:Upload 98.31%
10:41:24:WU01:FS00:Upload 91.80%
10:41:27:WU00:FS00:Upload 92.93%
10:41:29:WU02:FS00:Upload 99.34%
10:41:35:WU01:FS00:Upload 92.49%
10:41:42:WU00:FS00:Upload 93.96%
10:41:44:WU01:FS00:Upload 93.51%
10:41:54:WU00:FS00:Upload 94.98%
10:41:57:WU01:FS00:Upload 95.23%
10:42:03:WU01:FS00:Upload 96.60%
10:42:05:WU00:FS00:Upload 97.03%
10:42:10:WU01:FS00:Upload 97.62%
10:42:12:WU00:FS00:Upload 98.06%
10:42:19:WU01:FS00:Upload 99.34%
10:42:25:WU01:FS00:Upload 100.00%
10:42:26:WU00:FS00:Upload 99.08%
10:49:19:WU04:FS00:0x21:Completed 17000000 out of 25000000 steps (68%)
11:01:44:WU04:FS00:0x21:Completed 17250000 out of 25000000 steps (69%)

Args: --child --lifeline 1367 /etc/fahclient/config.xml --run-as fahclient --pid-file=/var/run/fahclient.pid --daemon

Version: 7.5.1
Date: May 11 2018
Time: 19:59:04
Repository: Git
Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
Branch: master
Compiler: GNU 6.3.0 20170516
Options: -std=gnu++98 -O3 -funroll-loops
Platform: linux2 4.14.0-3-amd64
Bits: 64
Mode: Release


Thanks,
Joseph

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: Unable to upload project 11730 to 128.252.203.2

Post by Joe_H » Mon Dec 10, 2018 4:36 pm

You have provided too little of the log to tell, but at least one WU is shown as reaching 100% uploaded. There is no acknowledgement of the receipt, that may have been lost or dropped by some part of your internet connection. That can be hard to diagnose, it could be your ISP, some hardware or software on your own systems, or somewhere between your ISP and this server.

It is possible the WU's have uploaded already. Could you provide the descriptions for the three WU's? I or one of the other moderators can check if they have uploaded. If they have, then you can remove them from your client.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

FijiRed2
Posts: 5
Joined: Thu Oct 14, 2010 10:03 pm

Re: Unable to upload project 11730 to 128.252.203.2

Post by FijiRed2 » Wed Dec 12, 2018 10:58 am

Evening Joe - where can I find the info you need? In the log window of FAHControl, I have the following:

04:52:52:WU01:FS00:Sending unit results: id:01 state:SEND error:NO_ERROR project:11730 run:0 clone:775 gen:131 core:0x21 unit:0x000000a68ca304e75bcd362ec5309ac0
04:52:52:WU01:FS00:Uploading 18.25MiB to 140.163.4.231
04:52:52:WU01:FS00:Connecting to 140.163.4.231:8080
04:52:52:WU02:FS00:Sending unit results: id:02 state:SEND error:NO_ERROR project:11730 run:0 clone:866 gen:154 core:0x21 unit:0x000000c48ca304e75bcd363941253d50
04:52:52:WU02:FS00:Uploading 18.25MiB to 140.163.4.231
04:52:52:WU02:FS00:Connecting to 140.163.4.231:8080
04:52:52:WU00:FS00:Sending unit results: id:00 state:SEND error:NO_ERROR project:11730 run:2 clone:952 gen:179 core:0x21 unit:0x000000ed8ca304e75bcd36e16440a0bd
04:52:52:WU00:FS00:Uploading 18.29MiB to 140.163.4.231
04:52:52:WU00:FS00:Connecting to 140.163.4.231:8080
04:52:52:WU03:FS00:Sending unit results: id:03 state:SEND error:NO_ERROR project:11730 run:2 clone:129 gen:160 core:0x21 unit:0x000000c78ca304e75bcbe5157a69d0fe
04:52:52:WU03:FS00:Uploading 18.28MiB to 140.163.4.231
04:52:52:WU03:FS00:Connecting to 140.163.4.231:8080
04:52:52:WU05:FS00:Starting

As you can see, I now have four WUs for project 11730 that are reporting as Send, with an ETA of "unknown".

Thanks for your guidance.
Joseph

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: Unable to upload project 11730 to 128.252.203.2

Post by Joe_H » Wed Dec 12, 2018 7:34 pm

All four have successfully uploaded to the server:
Hi FijiRed2 (team 45104), Your WU (P11730 R0 C775 G131) was added to the stats database on Wed, 12 Dec 2018 18:48:33 GMT for 38138.8 points of credit.
Hi FijiRed2 (team 45104), Your WU (P11730 R0 C866 G154) was added to the stats database on Wed, 12 Dec 2018 18:48:33 GMT for 38358.8 points of credit.
Hi FijiRed2 (team 45104), Your WU (P11730 R2 C952 G179) was added to the stats database on Wed, 12 Dec 2018 18:48:33 GMT for 26585.4 points of credit.
Hi FijiRed2 (team 45104), Your WU (P11730 R2 C129 G160) was added to the stats database on Wed, 12 Dec 2018 18:48:33 GMT for 38231.9 points of credit.
You can ignore the date shown, there is a glitch in the moderator query that shows the last time the database was updated instead of the actual time the WU was entered into it. The actual times for these being credited were shown in a different field I could not copy, and range from yesterday to nearly a week ago.

As I mentioned in my first post, this points towards acknowledgement packets getting dropped or lost. What the end of an upload in your log should look like is this:

Code: Select all

11:21:22:WU00:FS00:Upload 89.56%
11:21:28:WU00:FS00:Upload 96.14%
11:21:33:WU00:FS00:Upload complete
11:21:33:WU00:FS00:Server responded WORK_ACK (400)
11:21:33:WU00:FS00:Final credit estimate, 6905.00 points
11:21:33:WU00:FS00:Cleaning up
That could be from a bad connection, failing hardware, firewall settings, network congestion, or other issues, and could be in your local network, ISP, or anywhere between there and the server. Also not getting back to your client are the server messages that the WU has already been received which would cause it to remove the WU from the upload queue.

If this was a general issue with this particular server more reports would be showing up here, so I suspect the problem is elsewhere. Information from running a traceroute or ping between your system and the server might shows if there are excessive delays or packet losses.

In the meantime you can remove these WU's from your upload queue. Depending on your system configuration, the simplest method might be to finish any current WU, pause the client, then delete the folding slot. Un-pausing the client should discard the WU's if there is no suitable slot to process them with. Then add the folding slot back.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: Unable to upload project 11730 to 128.252.203.2

Post by Joe_H » Wed Dec 12, 2018 7:39 pm

One additional note, these 4 WU's all show as being uploaded to 140.163.4.231, not 128.252.203.2. Do you have any log entries showing problems uploading to 128.252.203.2?
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to upload project 11730 to 128.252.203.2

Post by bruce » Thu Dec 13, 2018 1:32 am

Are you connected directly to the internet or are your connections passing through a prosyserver? There have been reports of problems associates with some proxy servers dropping a few of FAH's informational replies.

When a WU is successfully uploaded, there's supposed to be a confirmation message sent to your client confirming that the local copy should be discarded. If that message is lost, the client will continue to try to upload the WU but the server will reject duplicate uploads so you'll have to delete it manually (after confirming that it WAS received).

FijiRed2
Posts: 5
Joined: Thu Oct 14, 2010 10:03 pm

Re: Unable to upload project 11730 to 128.252.203.2

Post by FijiRed2 » Thu Dec 13, 2018 8:12 am

Hi team,

Joe - I picked the IP address 128.252.203.2 as this shows as the collection server in fahclient. FAHClient shows 140.163.4.231 as the work server, and the Log shows that as server being uploaded to.

Bruce - I have a new DSL install, I was previously using a wifi box from the same ISP. I'm not using a proxy.

Thank You for your help,
Joseph

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to upload project 11730 to 128.252.203.2

Post by bruce » Thu Dec 13, 2018 8:20 pm

There are many servers which periodically are used as Collection Servers ... and they're selected at various times, so you cannot depend on which CS will be used. It's true that the WS 140.163.4.231 is currently using 128.252.203.2 as its CS. Both are currently on-line and running normally. I'm not sure what additional help may be provided, at this point.

Post Reply

Return to “Issues with a specific server”