Unable to fold via Linux

If you're new to FAH and need help getting started or you have very basic questions, start here.

Moderators: Site Moderators, PandeGroup

Post Reply
rayers100
Posts: 1
Joined: Wed Dec 12, 2018 5:00 am

Unable to fold via Linux

Post by rayers100 » Wed Dec 12, 2018 5:07 am

Hello everyone,
I have a Dell Optiplex 360 running Ubuntu 14.04 (32-bit). I can fold on my gaming rig no problem but my client on my linux machine keeps returning "Connection refused" and when i try to fold via Chromium it cant find my client and it also tries to tell me im not using chrome or im out of date, which it isn't. I would like to use this machine as a 24/7 folder as it consumes less power and i dont have to worry about the computer i use everyday blowing up. Anyone know whats going on here?

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to fold via Linux

Post by bruce » Thu Dec 13, 2018 1:18 am

Without information from your log, (see below) we can only guess ... but I have a vague memory that support for 32-bit linux has been discontinued. I'd suggest you upgrade to 64-bit linux. Personally I've used 14.04 and later versions, but they were all 64-bit.

ProDigit
Posts: 243
Joined: Sun Dec 09, 2018 10:23 pm

Re: Unable to fold via Linux

Post by ProDigit » Sun Dec 16, 2018 3:54 pm

I have the same situation on GalliumOs 2.1 (16.04 LTE, which also uses deb files and is based off Xubuntu, which is based off Ubuntu).
Same issues.
The client remains passive.
Best bet for now, is to install Google Chrome browser, and run the NaCl Client from the browser.

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to fold via Linux

Post by bruce » Tue Dec 18, 2018 2:51 am

There's a script (/etc/init.d/FAHClient) that starts FAHClient automatically at boot time. It should then continue to run as a daemon. If that script is not working, you'll have to decide why it didn't install properly or if FAHClient is encountering a fatal error and shutting down.

One of the most common reasons for it to crash is if you manually introduced errors into the config file. FAHClient doesn't diagnose those errors. Can you start it with the default copy of config?

"Connecting" generally means FAHClient crashed -- or it could be an anti-spyware add-on that blocking a telnet connection to 127.0.0.1 36330

ProDigit
Posts: 243
Joined: Sun Dec 09, 2018 10:23 pm

Re: Unable to fold via Linux

Post by ProDigit » Tue Dec 18, 2018 3:52 am

I think for linux it should be mentioned if a restart is needed.
Most programs run right after install.
Even system upgrades (core updates or upgrades) can run without reboot.

The problem is that the client .deb package on the site, is defective.
The RPM package (after conversion in Alien) installs fine, but also doesn't work.

After a reboot, still no luck.

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to fold via Linux

Post by bruce » Tue Dec 18, 2018 7:00 pm

What errors are encountered with the published version of the .deb?
See https://github.com/FoldingAtHome/fah-issues/issues/1217

ProDigit
Posts: 243
Joined: Sun Dec 09, 2018 10:23 pm

Re: Unable to fold via Linux

Post by ProDigit » Tue Dec 18, 2018 10:23 pm

Thanks, I'll get working on a bug report.

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to fold via Linux

Post by bruce » Wed Dec 19, 2018 7:48 pm

Be sure that each bug report describes a SINGLE problem.

You can add details to an existing report as long as you create a new one as long as something else needs to be fixed.

ProDigit
Posts: 243
Joined: Sun Dec 09, 2018 10:23 pm

Re: Unable to fold via Linux

Post by ProDigit » Fri Dec 21, 2018 12:25 pm

Ok, the issue seems to be resolved.
The Deb package is working fine on Xubuntu 19.10.
GalliumOs uses 16.04 (LTE), and is very old. I guess the deb package only works with more up to date versions of Linux.

Joe_H
Site Admin
Posts: 4482
Joined: Tue Apr 21, 2009 4:41 pm
Hardware configuration: iMac 2.8 i7 12 GB smp8
Mac Pro 2.8 quad 12 GB smp4
MacBook Pro 2.9 i7 8 GB smp3
Power Mac G4 dual 1.73 1.5 GB (retired)
Location: W. MA

Re: Unable to fold via Linux

Post by Joe_H » Fri Dec 21, 2018 4:33 pm

That is probably connected to GalliumOS and its packaging, not Ubuntu. I have a system that I installed folding on which runs Ubuntu 16.04, I had no such issues getting folding to work. Main issues I did have were related to getting all OpenCL support libraries installed for GPU folding.
Image

iMac 2.8 i7 12 GB smp8, Mac Pro 2.8 quad 12 GB smp6
MacBook Pro 2.9 i7 8 GB smp3

bruce
Posts: 22470
Joined: Thu Nov 29, 2007 10:13 pm
Location: So. Cal.

Re: Unable to fold via Linux

Post by bruce » Fri Dec 21, 2018 5:29 pm

Have you considered installing Ubuntu directly? GalliumOS is an "unsupported" distro and while we might make some lucky guesses, we're really not in a position to understand what might be different.

ProDigit
Posts: 243
Joined: Sun Dec 09, 2018 10:23 pm

Re: Unable to fold via Linux

Post by ProDigit » Sat Dec 22, 2018 7:32 am

Gallium OS had too many deb packages, as well as online packages that would error when installing.
Like a good 4 programs out of 20 had errors.
I switched to Xubuntu, and it works like a charm.

Post Reply

Return to “New Donors start here”